Installation Hangs at 50% - Seeking Assistance

I’m currently facing an issue during the installation of Concrete CMS, and I’m seeking assistance from the community to resolve it.

I’ve followed the Installation Guide carefully, but my installation process consistently hangs at 50%, and I’m unable to proceed further. I’ve double-checked server requirements, permissions, and even tried a fresh download of the installation package, but the problem persists.

Has anyone else encountered a similar issue during Concrete CMS installation? If so, how did you overcome it? Any insights, troubleshooting tips, or specific steps to resolve this would be greatly Concrete CMS?

What error are you getting? Can you share a screenshot? You could possibly be having max execution time issues. See: Getting Error after waiting for installation to complete

Like @enlil mentioned it might be worth upping your max execution time, or talking with your hosting provider about doing so - it might just be set really low and not allowing operations complete that need to do so in order for Concrete to complete installation.

To add to this, I did a fresh 9.2.2 install tonight. Hung somewhere along the lines and was errored out when I returned to my desk. Max execution time was set to 30 seconds. I changed this to 60 and the install worked no problem!

I always use the CLI to install or update Concrete. Avoids any timeout issues. Adjust the below:

concrete/bin/concrete5 c5:install --db-server=localhost --db-username=XXXX --db-password=YYYY --db-database=AAAA --site=BBBB --starting-point=atomik_full --admin-email=CCCC --admin-password=ZZZZ --site-locale=en_G
B --timezone=Europe/London

concrete/bin/concrete5 c5:update