V9.1.1 - bug in event list block when using specific topic filtering?

Hi there

I’m struggeling with a problem with v9.1.1 hoping someone of you guys is able to help me.

On a event list block I edited I want to use the standard filtering method over “Specific Topics” I created.
I used to do this with v8.5.6 and lower and it worked perfectly (see screenshot 1b: Screenshot_01b_event-list-edit_working-C5-v856.jpg).
Unfortunately in v9.1.1 the selected “Topic Attribute” (here: “News Topics”) doesn’t show the checkboxes menu anymore (see screenhot 1a: Screenshot_01a_event-list-edit_broken-CCMS-v911.jpg with the Topic Attribute I created: Screenshot_02_calendar_attribute-edit.jpg). The dropdown doesn’t work.
After saving the event list block and trying to publish the page the page runs into a SyntaxErrorException.

I made a second test which shows something with some of the event list block functions seems to go wrong: when choosing “No topic filtering” and saving the event list block and editing it again, the filtering method now shows “Current page” (see screenshot 4: Screenshot_04_event-list-edit_second-try.jpg).

Am I missing something (which I doubt because I reproduced exactly the working event liste functionality I use on another website running Concrete5 v8.5.6)? Or is this a known/unknown bug? If so, does a temporary fix exist?

Many thanks for your feedback!

Cheers, Rob

EDIT: Sorry, as a new user to the forums I’m allowed to only upload one file and not all the five screenshots I prepared for illustration of my problem.

Hi Robert,
Are you able to provide your environment information so we can reproduce your issue? which version of PHP is being used, and other important information. All of this information can be found summarized in the Dashboard > System & Settings > Environment > Environment
Thank you so much!

Thank you!

Just a bump on this one @RobR - if you can give us your environment information, we can try to reproduce and hopefully get you a resolution - thanks!

Sorry for late reply. I have been too busy,
My environment information in teh following - it’s a fresh local install of Concrete CMS 9.1.1 I made today. I still have the same problem.
If useful for you being able to reproduce the behaviour I’m able to provide step by step guide what I did and what happens (including some screenshots) in a few hours. Please feedback if you want it.

Thanks for looking into it.
Cheers, RobR

Environment information

Concrete Version

Core Version - 9.1.1
Version Installed - 9.1.1
Database Version - 20220516191423

Database Information

Version: 5.7.33

Concrete Packages


Concrete Overrides


Concrete Cache Settings

Block Cache - Off
Overrides Cache - Off
Full Page Caching - Off
Full Page Cache Lifetime - Every 6 hours (default setting).

Server Software

Apache/2.4.47 (Win64) OpenSSL/1.1.1k PHP/7.4.19

Server API


PHP Version


PHP Extensions

apache2handler, bcmath, calendar, Core, ctype, curl, date, dom, exif, fileinfo, filter, gd, hash, iconv, intl, json, libxml, mbstring, mysqli, mysqlnd, openssl, pcre, PDO, pdo_mysql, Phar, readline, Reflection, session, SimpleXML, SPL, standard, tokenizer, xml, xmlreader, xmlwriter, xsl, zip, zlib

PHP Settings

max_execution_time - 36000
log_errors_max_len - 1024
max_file_uploads - 20
max_input_nesting_level - 64
max_input_time - 60
max_input_vars - 1000
memory_limit - 512M
post_max_size - 2G
upload_max_filesize - 2G
mbstring.regex_retry_limit - 1000000
mbstring.regex_stack_limit - 100000
mysqli.max_links - Unlimited
mysqli.max_persistent - Unlimited
pcre.backtrack_limit - 1000000
pcre.recursion_limit - 100000
session.cache_limiter - no value
session.gc_maxlifetime - 7200
unserialize_max_depth - 4096

Any news on that? Just tried brand new version 9.1.2RC1 install. Still same issue: in event list block filtering by specific topic doesn’t work. @jessicadunbar @EvanCooper

Are you able to use php 8? Many hosts have a multiphp settings you can switch up.

@jes Same behaviour/issue after having switched php to 8.0 and tried again.

@RobR I’ll see if we can replicate.

Thanks a lot. In the meanwhile I filed an issue here: https://github.com/concretecms/concretecms/issues/10808
I decided so because I have been using this clever feature a lot in my version 8 websites so far and it has been working perfectly.


This has been fixed and will be released in 9.1.2. Thank you for all the details.

Yes, thanks Jess. I just noticed it myself a few days ago on Github. The fixed files used as a hotfix on my systems using version 9.1.1 and 9.1.2RC1 worked for me as expected.