What kind of joke is this? Twitter to X

update to 9.2.3 - what is it?
I gave up on my activity to reduce my stress level, but the last update seems to have ruined that.

it was just an icon change - how could it be messed up?

Elon would approve though. Big as his ego! I see myself out now, not helpful I know…
(Maybe SVG instead of PNG’s?)


See 9.2.4 Release Notes :: Concrete CMS


thanks, I didn’t know that another version has already been released

yeah, you gotta keep Elon happy too bro… :wink:


We updated to 9.2.4 and using the Atomic theme. We are still display the big X. goldenspike.ca

We did customise the footer.php to add an extra section to display extra images (9.2.4 version).

Thanks for any assistance. Peter

1 Like

The problem here is that the X icon doesn’t appear in Font Awesome, which is what we use for our icons. So we are including the X icon as an SVG. However the existing style sheets don’t have any entries for ensuring that SVG social icons appear at the proper size.

The Atomik theme stylesheet already has this new support for SVG social icons at the proper size. Please make sure to clear your browser’s cache.

If that doesn’t do the trick, it might be because you’ve built custom Atomik skins. These will have to be re-saved, because they’re compiled from a previous version’s source files (which didn’t have the SVG). So go into the theme customizer, update a value and re-save the skin. That should fix the large X.

If you’re using a custom theme and you’re seeing the large X, you’ll likely have to add support for the svg icon into your SASS/LESS/CSS. Something like

.ccm-block-social-links {
  svg {
    max-height: 13px;
1 Like

Thanks Andrew it worked.

Yes, we did customise the colour scheme. I changed a value in our customised version of Atomik and saved. I then cleared the Cache and waited 24 hours.

Happy holidays. Peter and the Golden Spike team.

Your solution works, but you only added the basic version (and some scarily skinny version of it), and where is square-twitter?



Maybe a better idea/solution would be to implement FA version 5 or 6 to ConcreteCMS, as they write on the FontAwesome website - 4 is old - diplomatically speaking. (this would also solve the inconsistencies with the Instagram icon)

Another thing is that this block stopped responding to the settings - I wanted to have the icons centered

@JohntheFish - thanks for the tip, but as you can see, it still doesn’t solve the problem

I have a slightly different issue with the X icon. Mine just doesn’t appear. It’s been that way since it was changed from Twitter to X. I’ve tried deleting the block, social link, clearing cache. Nothing seems to do the trick. I can see the SVG in the code, but it doesn’t display. You can see the block live in the footer of https://blvdtheatres.com (using the Atomik theme)

1 Like

I can see the X icon:

Did you try to clear the cache of the browser?

I did clear the browser cache. And have tried multiple browsers. Two screenshots attached from my phone, but it matches on my computer as well.

1 Like

First look, I see it also…

What core version are you on? You will need 9.2.4 to see the X properly and 9.2.3 to see if big.

I’m on version 9.2.4

1 Like

that’s a good point - x does not appear on mobile - thanks for the info (9.2.4)

and in the Shate This Page block


and this is crazy

The Social Link block maintains position (centering as it should) but does not respect size changes

@andrew , @frz would you give us any hint, please - even a temporary bypass - I believe that the fix will be released in January (honestly - and I think I’m not the only one who would be happy, preferably in the form of an FA5 or 6 implementation)

If you add css style:

.ccm-block-share-this-page a[aria-label="X"] svg {
  width: 9px;
  margin-top: -2px;
li.list-inline-item [aria-label="X"] {
  display: block;
  width: 20px;

I think you should be fine for the moment.

1 Like

Thanks for that. :+1: It solved one of the problems.

Do you know if there is a way to restore the old Twitter settings to these blocks?

Don’t know about the old version. Guess you’d need to look into the view.php and view.css of the old version and change things in the new version accordingly.

But the 𝕏 is actually close to a mathematical sign that is represented in Unicode. So you could probably exchange the whole SVG code simply with a <span style="font-size: 30px; margin-top: -8px; display: block;>𝕏</span> and just Tweak the font-size to your needs depending on where you add it. The 𝕏 is close enough to the one of Twitter that anyways nobody will spot the difference.

For a temporary solution if the other one does not suffice for your needs.

1 Like

Thank you once again for your help in patching this, for now, I will stick to it, hoping that in January there will be a fix that will adequately address the problems.