Cannot see project assigned add-on to download and install on website

I am running a new site on 9.3.1 and have connected the client’s site to the new marketplace.
I have selected the ‘Cookies Consent’ add-on by Ryan Hewitt and assigned a license to my client’s website in the marketplace but it just doesn’t appear in the ‘Extend Concrete’ page for installation?
I have clicked back and forth from the website and the marketplace and tried unassigning and re-assigning a license but I just cannot get it to come up and allow me to install it on the website.

I have also checked the website and marketplace connection keys and they are all matching.

Is this just me or are others having this issue?

There are other forum threads reporting an inability to download, though I don’t know if they correlate exactly with this.

If you mention @frz and @Myq you will draw their attention to the problem (no need here as I have just mentioned them)

I have been sending customers zip files by weTransfer.

I’ve checked the listing, and it appears that the previous compatibility setting haven’t been pulled across.

But I also can’t actually set them:

From looking at the rest of the listing, it looks to be both approved:

And not approved at the file level:

@JohntheFish, is that something you can adjust from your PRB role?

@mesuva, us PRB folks have an ongoing problem (reported to @frz) of being unable to approve any addon or update since the new marketplace went live.
(we were able to approve while the new marketplace was being tested).

We also have a further problem that we are not receiving notifications of anything requiring approval - which is probably a good thing as all we can do at present is say ‘notify @frz

1 Like

And the scenario I described for @frz moments ago begins. I’m going to pretend I can’t go see how many packages are bugged out from this right now :confused:

I’ll bump topic for visibility/attention, since I am waiting for “zip file” approval myself (I have swapped packages to latest version).

Turns out there was an unapproved file and nothing set to serve to 9.3.1 for that add-on.
I’ve just approved the package and assigned it to 9.3.1.
If you go back to Extend in your site, it should appear there now?

Thats interesting. cookie consent just appeared in ‘add functionality’ I think I previously selected it but it never showed up. I still can’t download it or any other marketplace items as others have reported :-

Here : Can't download new add-ons and themes


Here : Can't install free add on from new market place

I can see it now but as I tried to download it I had this error?

1 Like

Yep! …exactly what I am experiencing.

1 Like

Bump! And me as well.

@darkmatter @joaquinvaldez and @studio108 This issue showed up in 9.3.0 and was supposed to be fixed in 9.3.1, but clearly not in all cases. Can you let me know the details of your hosting environment (maybe in a direct message since it’s not really the topic of this thread) or add details to this GitHub issue: rename() fails when installing packages · Issue #12084 · concretecms/concretecms · GitHub

@Myq I updated the github issue. Thanks!

1 Like

@joaquinvaldez if you have the ability to do so, could you see if this fixes your issue? @darkmatter and @studio108 as well. Don’t worry if you don’t feel comfortable making that change.

1 Like

Giving it a try! Thank you.

1 Like

@Myq Yes, in my case it worked just fine! Thank you.

1 Like

@Myq worked for me also. Just downloaded and installed crista theme.
BTW my /tmp is on same partition as site install.

Thank you!

1 Like

Sorry for the late reply. Yes this worked for me and I see the fix will be included in 9.3.2. Thank you for your excellent help.

1 Like

I also was able to get this resolved by manually applying the fix from above on 9.3.1.

1 Like

FYI: 9.3.2 has just been released and includes this fix: GitHub - concretecms/concretecms at 9.3.2